Back to overview
Downtime

Couldn't Connect to Server

Feb 07 at 10:17pm HST
Affected services
Maezkev Portfolio

Resolved
Feb 07 at 10:23pm HST

The issue resolved itself, and normal operations resumed automatically after a brief downtime.

Created
Feb 07 at 10:17pm HST

The Maezkev Portfolio was temporarily down due to a "Couldn't connect to server" error across multiple regions.